Note: The other languages of the website are Google-translated. Back to English

Hogyan lehet értéket találni egy cellában vesszővel elválasztott listával az Excelben?

Ha feltételezzük, hogy van egy oszlop, vesszővel elválasztott értékeket tartalmaz, például Értékesítés, 123, AAA, és most meg szeretné találni, hogy a vesszővel elválasztott cellában a 123-as érték hogyan lehet? Ez a cikk bemutatja a probléma megoldásának módszerét.

Keressen értéket egy cellában vesszővel elválasztott listával és képlettel


Keressen értéket egy cellában vesszővel elválasztott listával és képlettel

A következő képlet segíthet abban, hogy értéket találjon egy cellában vesszővel elválasztott listával az Excelben. Kérjük, tegye a következőket.

1. Jelöljön ki egy üres cellát, írja be a képletet =IF(ISNUMBER(SEARCH(123,A2)),"yes","no") a Formula Bar-ba, majd nyomja meg az Enter billentyűt. Lásd a képernyőképet:

Megjegyzések: A képletben A2 a cella tartalmazza a vesszővel elválasztott értékeket.

2. Folyamatosan válassza ki az eredmény cellát, és az összes eredmény eléréséhez húzza lefelé a Kitöltő kezelőt. Ha a „123” érték szerepel a vesszővel elválasztott cellákban, akkor az eredmény „Igen”; különben az eredményt nemként kapja meg. Lásd a képernyőképet:


Kapcsolódó cikkek:


A legjobb irodai termelékenységi eszközök

A Kutools for Excel megoldja a legtöbb problémát, és 80% -kal növeli a termelékenységet

  • újrafelhasználás: Gyorsan helyezze be összetett képletek, diagramok és bármi, amit korábban használt; Cellák titkosítása jelszóval; Levelezőlista létrehozása és e-maileket küldeni ...
  • Szuper Formula Bár (könnyedén szerkeszthet több szöveget és képletet); Olvasás elrendezés (könnyen olvasható és szerkeszthető nagyszámú cella); Beillesztés a Szűrt tartományba...
  • Cellák / sorok / oszlopok egyesítése az adatok elvesztése nélkül; Osztott cellák tartalma; Kombinálja a duplikált sorokat / oszlopokat... megakadályozza az ismétlődő cellákat; Hasonlítsa össze a tartományokat...
  • Válassza a Másolat vagy az Egyedi lehetőséget Sorok; Válassza az Üres sorok lehetőséget (az összes cella üres); Super Find és Fuzzy Find sok munkafüzetben; Véletlenszerű kiválasztás ...
  • Pontos másolás Több cella a képletreferencia megváltoztatása nélkül; Automatikus referenciák létrehozása több lapra; Helyezze be a golyókat, Jelölőnégyzetek és még sok más ...
  • Kivonat szöveg, Szöveg hozzáadása, Eltávolítás pozíció szerint, Hely eltávolítása; Hozz létre és nyomtasson személyhívó részösszegeket; Konvertálás a cellatartalom és a megjegyzések között...
  • Szuper szűrő (mentse el és alkalmazza a szűrősémákat más lapokra); Haladó rendezés hónap / hét / nap, gyakoriság és egyebek szerint; Speciális szűrő félkövér, dőlt betűvel ...
  • Kombinálja a munkafüzeteket és a munkalapokat; Táblázatok egyesítése kulcsoszlopok alapján; Az adatok felosztása több lapra; Kötegelt konvertálás xls, xlsx és PDF...
  • Több mint 300 hatékony funkció. Támogatja az Office / Excel 2007-2021 és 365 verziókat. Minden nyelvet támogat. Könnyű üzembe helyezés vállalatában vagy szervezetében. Teljes funkciók 30 napos ingyenes próbaverzió. 60 napos pénzvisszafizetési garancia.
kte lap 201905

Az Office fül a füles felületet hozza az Office-ba, és sokkal könnyebbé teszi a munkáját

  • Füles szerkesztés és olvasás engedélyezése Wordben, Excelben és PowerPointban, Publisher, Access, Visio és Project.
  • Több dokumentum megnyitása és létrehozása ugyanazon ablak új lapjain, mint új ablakokban.
  • 50% -kal növeli a termelékenységet, és naponta több száz kattintással csökkenti az egér kattintását!
officetab alja
A megjegyzések rendezése szerint
Hozzászólások (16)
Még nincs értékelés. Legyen Ön az első, aki értékel!
A weboldal moderátora ezt a megjegyzést minimalizálta
Jó reggelt mindenkinek. Lenne egy excel-kérdésem, hogy hogyan számolhatok meg vesszővel elválasztott értékeket egyetlen cellában az Excelben. Szeretnék 15-öt számolni egyetlen cellában, amely 15,215,15,155,45,1515,15-öt tartalmaz. eredmény 3. Van-e képlet az Excelben.
A weboldal moderátora ezt a megjegyzést minimalizálta
Igen, az Excelben van egy funkció, amely ezt megteheti. Azonban, amint azt a fenti probléma kifejti, az adatok pontosabbá tétele érdekében írjon vesszőt a lista bal és jobb oldalára, és vegye fel a keresésbe. Lásd az alábbi példát:
, 15,215,15,155,45,1515,15,
=COUNTIF(A1; ",15")
Ennek a képletnek a magyarázata a következő: =COUNTIF(cellaszám vagy tartomány, a keresett érték/számlálás)
Szólj, ha jobb példára van szükséged.
A weboldal moderátora ezt a megjegyzést minimalizálta
Helló!
Ez egy nagyon klassz formula, de van... hibája? ... hogy nem tudom, hogyan lehetne megkerülni. A "hiba" nem a megfelelő szó, de nem tudok rájönni (hétfőn reggel 8:30 van) a megfelelő szóra.
Ha egy szám bármely részét keresi, „igen”-t kap. Tehát a következők mindegyike "igen"-t ad vissza:
=HA(ISSZÁM(KERESÉS(12;A2)),"igen","nem")
=HA(ISSZÁM(KERESÉS(23;A2)),"igen","nem")
=HA(ISSZÁM(KERESÉS(3;A2)),"igen","nem")

Hiába próbáltam idézőjelbe tenni a számokat. A képlet tökéletesen működik a példa használati esetére, ahol az összes szám azonos hosszúságú. De ha egy rövidebb számot keres, amely történetesen megjelenik a karakterláncban, hamis pozitív eredményt kap.
Van-e a "KERESÉS" szó szerintibb alternatívája (megint ez a szó? haha)? 
Köszönjük! 
A weboldal moderátora ezt a megjegyzést minimalizálta
Szia Scott S.! A pontos karakterláncra gondolsz?
A weboldal moderátora ezt a megjegyzést minimalizálta
Szia Crystal.
Igen, azt hiszem, így kell megfogalmazni. 
A jelenlegi megoldás „Igen”-t ad vissza a számsor bármely részére. Tehát az 1, 2, 3, 12, 23 és 123 számok mindegyike „Igen”-t ad vissza. 
Megpróbáltam olyan megoldást kidolgozni, amely egy számsort keres, és az „Igen”-t adja vissza a pontos egyezéshez. 
A weboldal moderátora ezt a megjegyzést minimalizálta
Szia Scott S! Köszönjük visszajelzését. Még nem találtam meg a megoldást, és visszajelzek, ha megtaláltam.
A weboldal moderátora ezt a megjegyzést minimalizálta
Erre találtam megoldást. Ha vesszőt ad a lista bal és jobb oldalához, és beleveszi őket (például szendvicset) a keresésbe, akkor pontos egyezést találhat. Példa alább:
, 123,231,321,122,321,1,2,3,23,
KERESÉS(",23")
Így arra kényszeríti a keresést, hogy az egyik vesszőről a másikra illeszkedjen, és ne csak egy része a lista bejegyzésének. Remélem, ezt kerested?
A weboldal moderátora ezt a megjegyzést minimalizálta
Találtam megoldást. Ha vesszőt ad a lista bal és jobb oldalához, akkor a keresési funkciónak meg kell találnia a vesszőtől a vesszőig terjedő pontos egyezést. Lásd az alábbi példát:
=HA(ISSZÁM(KERESÉS(",12;",A2)),"igen","nem")

, 312,123,10,112,126,
Ez false értéket ad vissza, mert nincs vesszőtől vesszőig (,12,) változó, amely megfelelne a keresésnek. 
Ha további felvilágosításra van szüksége, tudassa velem, és írjon be egy jobb példát. Ugyanez a probléma volt, amikor automatizáltam a jelentést a főnököm számára, és epifánia volt. :)
A weboldal moderátora ezt a megjegyzést minimalizálta
Hé, ezt még mindig nem értem. Még mindig ugyanaz a probléma. a képletben a szám helyett cellahivatkozást használok. például ha az "1"(Q$1) kifejezést keresem a (123, 25,29,200)($J2) mezőben, akkor is IGEN-t ad. A képlet a következő: =HA(ISSZÁM(KERESÉS(Q$1,$J2)),"igen","nem")

PS: Nagy adatkészletem van, nem tudok minden cellába vesszőt tenni elé és után. Értékelni fog egy megoldást
A weboldal moderátora ezt a megjegyzést minimalizálta
Szia Kérem segítsen

Van egy táblám az Excelben két oszloppal A és B 2 és 1,2,2,1,2,1,2 a teljes cellában, és nincs más szám) és A1-ban 2 és A1-ben 2, A3-ben 1,1,1 és A4-ban 0. Azt akarom, hogy B5 adja vissza az A2,2,2,2 értékét Ázsiaként , B6 Afrika, B20 mint Nincs, B2 mint Amerika és B2 mint Európa. Azt hittem, használhatom az if formulát, de nem képes felismerni a vesszővel elválasztott számokat és a visszatérési értéket). Kérem, segítsen
A weboldal moderátora ezt a megjegyzést minimalizálta
Mit szólnál ehhez, kérem, megkapjam az A-beli értékeket, és egyenlővé kell tennem őket a C-beli számokkal, és vissza kell adnom a B-beli értékeket vesszővel elválasztva C-be.

Kösz
A weboldal moderátora ezt a megjegyzést minimalizálta
Szia Duncan,
Ha Excel for 365-öt használ, a következő képlet segíthet a probléma megoldásában.
=TEXTJOIN(",",TRUE,XLOOKUP(TRANSPOSE(VALUE(TEXTSPLIT(D1,","))),A1:A3,B1:B3,"",0,1))
Ez a képlet csak a 365-ös Excelben működik. A 365-ös Excel-től eltérő Excel-verziókhoz nem találtam olyan képletet, amely kezelné.
https://www.extendoffice.com/images/stories/comments/comment-picture-zxm/find-value.png
A weboldal moderátora ezt a megjegyzést minimalizálta
Sziasztok! Van egy cellám, amelyben több ország van vesszővel elválasztva
Példa: Az A2 cella értéke (India, Japán, Malajzia, Nagy-Kína)
A G oszlopban az országok nevei szerepelnek
Most keresnem kell egy képletet, amely összehasonlítja a G oszlop értékét az A2-es cellában lévő értékkel.
Ha az érték megegyezik, akkor adja vissza az igaz értéket, ellenkező esetben adja vissza a False értéket
A weboldal moderátora ezt a megjegyzést minimalizálta
Szia Mohini Verma!
A képlet a következőképpen módosítható:
=HA(ISSZÁM(KERESÉS(G2,A2)),"IGAZ","HAMIS")
A weboldal moderátora ezt a megjegyzést minimalizálta
Hé, ezt még mindig nem értem. Még mindig ugyanaz a probléma. a képletben a szám helyett cellahivatkozást használok. például ha az "1"(Q$1) kifejezést keresem a (123, 25,29,200)($J2) mezőben, akkor is IGEN-t ad. A képlet a következő: =HA(ISSZÁM(KERESÉS(Q$1,$J2)),"igen","nem")

PS: Nagy adatkészletem van, nem tudok minden cellába vesszőt tenni elé és után. Értékelni fog egy megoldást
A weboldal moderátora ezt a megjegyzést minimalizálta
Szia Hassam

Csak használja a következő képletet az IF függvény nélkül. Ha a szám pontosan egyezik, akkor az eredményt kapja "TRUE", különben meglesz az eredmény"HAMIS".
=ISNUMBER(KERESÉS(",1,",","&$J2&","))
https://www.extendoffice.com/images/stories/comments/comment-picture-zxm/match.png
Még senki sem írt megjegyzést
Hagyja meg észrevételeit
Feladás vendégként
×
Értékeld ezt a bejegyzést:
0   Karakterek
Javasolt helyek

Kövess minket

Copyright © 2009 - www.extendoffice.com. | Minden jog fenntartva. Powered by ExtendOffice. | Oldaltérkép
A Microsoft és az Office logó a Microsoft Corporation védjegyei vagy bejegyzett védjegyei az Egyesült Államokban és / vagy más országokban.
Sectigo SSL védi