Ugrás a tartalomra

Excel ISERR függvény

Az ISERR függvény bármilyen hibatípus esetén IGAZ értéket ad vissza (kivéve #N/A), egyébként pedig FALSE-t.

iserr függvény 1


Szintaxis

=ISERR(value)


érvek

  • érték (kötelező): A tesztelni kívánt érték, ha ez bármilyen hiba, de #N/A.

Visszatérési érték

Az ISERR függvény IGAZ vagy HAMIS értéket ad vissza.


Megjegyzések a funkcióról

  • Az ISERR-t gyakran használják az IF függvénnyel együtt egyéni üzenet megjelenítésére vagy egyéb számítások elvégzésére, ha hibát talál, pl. =HA(ISERR(A1),"üzenet"), =SZUM(--ISERR(A1:A10)).

Példa

Vegyük példaként az alábbi táblázatot. A táblázatban felsorolt ​​értékek teszteléséhez, ha azok hibatípusok, de #N/A, kérjük, másolja ki vagy írja be az alábbi képletet a felső cellába, nyomja meg a belép az eredmény eléréséhez, majd húzza le a kitöltő fogantyút (az eredménycella jobb alsó sarkában), hogy alkalmazza a képletet az alábbi cellákra.

=ISERR(B3)

iserr függvény 2


Kapcsolódó funkciók

Excel ISBLANK függvény

Az ISBLANK függvény IGAZ értéket ad vissza, ha egy cella üres vagy üres, ellenkező esetben pedig HAMIS értéket ad vissza.

Excel ISERROR függvény

Az ISERROR függvény bármilyen hibatípus esetén IGAZ értéket ad vissza, egyébként pedig FALSE-t.

Excel ISLOGICAL függvény

Az ISLOGICAL függvény logikai érték esetén TRUE-t, egyébként FALSE-t ad vissza.

Excel ISNA függvény

Az ISNONTEXT függvény IGAZ értéket ad vissza a #N/A hibaértékre, ellenkező esetben pedig FALSE-t.

Excel ISNONTEXT függvény

Az ISNONTEXT függvény TRUE-t ad vissza olyan érték esetén, amely nem szöveg, egyébként pedig FALSE-t.

Excel ISNUMBER függvény

Az ISNUMBER függvény egy szám esetén IGAZ értéket, egyébként pedig HAMIS értéket ad vissza.

Excel ISREF függvény

Az ISREF függvény referencia esetén IGAZ értéket, egyébként FALSE értéket ad vissza.

Excel ISTEXT függvény

Az ISTEXT függvény IGAZ értéket ad vissza szöveges érték esetén, egyébként pedig FALSE-t.


A legjobb irodai termelékenységi eszközök

Kutools for Excel - segít kitűnni a tömegből

Népszerű szolgáltatások: Ismétlődések keresése, kiemelése vagy azonosítása  |  Üres sorok törlése  |  Oszlopok vagy cellák kombinálása adatvesztés nélkül  |  Kerek Formula nélkül ...
Szuper VLookup: Több kritérium  |  Több érték  |  Több lapon keresztül  |  Fuzzy Lookup...
Adv. Legördülő lista: Egyszerű legördülő lista  |  Függő legördülő lista  |  Többszörösen válassza ki a legördülő listát...
Oszlopkezelő: Adjon meg egy adott számú oszlopot  |  Oszlopok mozgatása  |  Kapcsolja be a Rejtett oszlopok láthatósági állapotát  Hasonlítsa össze az oszlopokat a Válassza az Ugyanaz és különböző cellák lehetőséget ...
Kiemelt funkciók: Rács fókusz  |  Design nézet  |  Nagy Formula bár  |  Munkafüzet és lapkezelő | Erőforrás-könyvtár (Auto szöveg)  |  Dátumválasztó  |  Kombinálja a munkalapokat  |  Cellák titkosítása/dekódolása  |  E-mailek küldése listánként  |  Szuper szűrő  |  Speciális szűrő (félkövér/dőlt/áthúzott szűrés...) ...
A 15 legjobb eszközkészlet12 szöveg Eszközök (Szöveg hozzáadása, Karakterek eltávolítása ...)  |  50 + Táblázatos Típusai (Gantt-diagram ...)  |  40+ Praktikus képletek (Számolja ki az életkort a születésnap alapján ...)  |  19 beszúrás Eszközök (Helyezze be a QR-kódot, Kép beszúrása az útvonalból ...)  |  12 Átalakítás Eszközök (Számok szavakig, Valuta átváltás ...)  |  7 Egyesítés és felosztás Eszközök (Haladó kombinált sorok, Az Excel cellák felosztása ...)  |  ... és több

A Kutools for Excel több mint 300 funkcióval büszkélkedhet, Győződjön meg arról, hogy amire szüksége van, csak egy kattintásnyira van...


Office lap – A lapos olvasás és szerkesztés engedélyezése a Microsoft Office programban (beleértve az Excelt is)

  • Egy másodperc a tucatnyi nyitott dokumentum közötti váltáshoz!
  • Csökkentse az egérkattintások százait az Ön számára minden nap, búcsút mondjon az egér kezének.
  • 50% -kal növeli a termelékenységet több dokumentum megtekintésekor és szerkesztésekor.
  • Hatékony lapokat hoz az Office-ba (beleértve az Excelt is), akárcsak a Chrome, az Edge és a Firefox.
Comments (0)
No ratings yet. Be the first to rate!
There are no comments posted here yet
Please leave your comments in English
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations